Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#444 closed improvement (fixed)

Notification emails

Reported by: ales.list Owned by:
Priority: minor Milestone: 7.4.1
Component: Calendar Version: 7.4
Keywords: Cc: ales.list@…

Description

Hello,

all notification mails are sent out of the system without replaced variables
example of email that is sent to user

From: dms@example.org 
Sent: Thursday, July 24, 2014 11:35 AM
Subject: $_description <hr/> $type: <b>$_type</b><br/> $subtype: <b>$_subType</b><br/> $begin: <b>$_startDate</b><br/> $expirationdate: <b>$_expirationDate</b><br/> <hr/> $_documents

$_description 
________________________________________
$type: $_type
$subtype: $_subType
$begin: $_startDate
$expirationdate: $_expirationDate
________________________________________
$_documents

thank you,

Ales

Change History (15)

comment:1 Changed 8 years ago by car031

Please try to reproduce again and post your repository\logs\dms.log right after

comment:2 Changed 8 years ago by ales.list

thank you,

Ales

comment:3 Changed 8 years ago by car031

Not able to discover issues in your log. We tried on a couple of fresh 7.0.1 here without this issue. What is the locale of the user that receives the email(the one you see in the language field of his profile?

What is the database you are using? (MySQL, Oracle or SQL Server)

comment:4 Changed 8 years ago by ales.list

Hello,

  • database engine is MySQL v5.1.73 (database engine used is clearly visible in logs)
  • all users have language field set to English in their profiles

Ales

comment:5 Changed 8 years ago by ales.list

Hello,

  • for test I changed language field of one of notified users
  • I will provide feedback after fresh mail storm

thank you

Ales

comment:6 Changed 8 years ago by car031

In this case we are really on trouble since we are not able to reproduct your problem.
Please write to support@… to book a remote session on your server.
We will probably need to enter the database also.

comment:7 Changed 8 years ago by ales.list

Hello,

  • mail for user with different language set in profile came trough with unresolved variables
  • I will provide download link with server backup (without library documents)

Ales

comment:8 Changed 8 years ago by ales.list

Hello,

thank you,

Ales

comment:9 Changed 8 years ago by car031

Nobody asked you a backup, and please drop that remote resource since this site is public.

No more posts will be accepted on this issue, please switch to support@… and agree on a remote session.
If you disregard the advice we will stop to support you on this.

comment:10 Changed 8 years ago by car031

  • Milestone 7.0.2 deleted
  • Priority changed from Major to Minor
  • Resolution set to worksforme
  • Status changed from new to closed

comment:11 Changed 7 years ago by ales.list

Hello,

any new idea after 16months
with v7.4 we noticed "change" in calendar notifications


From: dms@… dms@…
Sent: Monday, November 30, 2015 3:04 PM
Subject: $product - $event.title

$event.description

$I18N.get('type'): $event.type
$I18N.get('subtype'): $event.subType
$I18N.get('begin'): $DateTool?.format($event.startDate, true)
$I18N.get('expirationdate'): $DateTool?.format($event.expirationDate, true)

$I18N.get('documents'): #foreach( $doc in $documents )
$doc.title | $I18N.get('download') | $I18N.get('display') #end


  • btw: AUDIT module is replacing variables ok

Br, Ales

comment:12 Changed 7 years ago by ales.list

  • Cc ales.list@… added
  • Component changed from Core to Calendar
  • Milestone set to 7.4.1
  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Type changed from Bug to Wish
  • Version changed from 7.0.1 to 7.4

comment:13 Changed 7 years ago by car031

  • Milestone 7.4.1 deleted

comment:14 Changed 7 years ago by car031

  • Milestone set to 7.4.1
  • Resolution set to fixed
  • Status changed from reopened to closed

comment:15 Changed 7 years ago by car031

  • Summary changed from notification emails to Notification emails
  • Type changed from Wish to Improvement
Note: See TracTickets for help on using tickets.