Opened 4 months ago

Closed 3 weeks ago

#1022 closed test (fixed)

multi-connection access via webdav client

Reported by: ericphua Owned by:
Priority: minor Milestone:
Component: WebDAV Version: 8.4
Keywords: Cc: brian_thong@…

Description

Hi Support,
We have an issue where we found out that when user access the logicaldoc via WebDAV using web drive client.

There are multiple connection created. After which, other users are not able to access anymore.

Attachments (3)

Capture.PNG (93.8 KB) - added by ericphua 4 months ago.
Mutliple connection shows
License.PNG (32.7 KB) - added by ericphua 4 months ago.
Version
patch-20200722.zip (11.4 KB) - added by admin 3 weeks ago.
Patch

Download all attachments as: .zip

Change History (15)

Changed 4 months ago by ericphua

Mutliple connection shows

Changed 4 months ago by ericphua

Version

comment:1 Changed 4 months ago by car031

The license admit a max. number of concurrent sessions.Are the sessions closed by the client? If not, when you reach the max. sessions, you cannot enter anymore, until when you free a slot by killing one of the actual sessions.

comment:2 Changed 4 months ago by ericphua

can I confirm 1 user is utilize 1 session connection only? we tested using only 1 user to connect but it created 18 sessions as in the attached photo.

comment:3 Changed 4 months ago by car031

i presume that the same user is generating more sessions. You see the list of all the sessions in http://<server_ip>:8080/sessions

comment:4 Changed 4 months ago by ericphua

The issue are sessions is up to 20, users are not able to access anymore. understand our purchased license is base on user (20), not sessions?

In the screen capture, we only have 1 user - HSA_AISYAHJ accessing

comment:5 Changed 4 months ago by ericphua

add on, we are actually trying to check if there is a bug, as only 1 user access and it created 18 sessions at one shot.

how can we check? thanks.

comment:6 Changed 4 months ago by car031

ok we double checked with Webdrive 2019 against LogicalDOC 8.4.2. The client connects to LogicalDOC using a single session. We tried multiple actions, browse / creation / rename / move, a single session has been used.

When the client disconnect or is closed, the user's session will continue to exist in LogicalDOC until the timeout: the webdav is sessionless and so the webdav client does not have a way to end a session.

comment:7 Changed 3 months ago by ericphua

Hi Support,
Share some weird findings:
For multiple sessions, if we were to login Admin account (default created during installation) via Web Drive client, only 1 session is created.

If to create new user account (logicaldoc user given admin rights) and login via Web Drive client, then it will create 18 sessions at a go.

comment:8 Changed 3 months ago by admin

  • Milestone changed from 8.4.3 to 8.5

Milestone renamed

comment:9 Changed 3 months ago by admin

  • Milestone 8.5 deleted
  • Priority changed from major to minor

comment:10 Changed 2 months ago by ericphua

Hi there, any findings or configuration changes that can advise? link below video showing when access logicaldoc via WebDAV client on 1 user, multiple sessions were created.

Apologize video too big to upload.
https://drive.google.com/file/d/1OCTuqB2QpIQwgxO5kF6gm786u_LhO8na/view?usp=sharing

comment:11 Changed 2 months ago by ericphua

#480 applied to WebDAV access? we can simulate the multiple sessions were caused by account name case sensitive input wrongly.

comment:12 Changed 3 weeks ago by admin

  • Resolution set to fixed
  • Status changed from new to closed

To fix this, upgrade your system to LogicalDOC 8.5 first.
Then do as follows:
1) Stop LogicalDOC
2) Unpack the attached patch into <LDOC_HOME>/tomcat/webapps/ROOT/WEB-INF/classes
3) Start LogicalDOC

Changed 3 weeks ago by admin

Patch

Note: See TracTickets for help on using tickets.