Opened 11 months ago

Closed 9 months ago

#879 closed improvement (fixed)

Record the reason for signing (compliance with medial standard 21CFR Part 11)

Reported by: gstrylewicz Owned by:
Priority: minor Milestone: 8.1
Component: Digital Signature Version: 8.0
Keywords: reason Cc:

Description

Electronic signatures used in medical research settings need to be 21CFR Part 11 compliant, which states, in part:
(a) Signed electronic records shall contain information associated with the signing that clearly indicates all of the following: (1) The printed name of the signer;
(2) The date and time when the signature was executed; and
(3) The meaning (such as review, approval, responsibility, or authorship) associated with the signature.
When I electronically sign a document, the reason is a required field and is added to the PDF, if configured for a visual sign. Otherwise, the reason is not recorded in the database and not displayed as part of the signing information.

Attachments (1)

21CFR11.pdf (150.2 KB) - added by gstrylewicz 11 months ago.
FDA requirements on esig, section 11.50

Download all attachments as: .zip

Change History (5)

Changed 11 months ago by gstrylewicz

FDA requirements on esig, section 11.50

comment:1 Changed 11 months ago by car031

  • Milestone 8.0.1 deleted
  • Priority changed from major to minor
  • Type changed from bug to wish

This is not a bug, this sounds like a wish or a feature request.
You reference a regulation but the compliance to that regulation in not in the LogicalDOC's features list. If you need this to be implementec shortly plase contact the sales to have a quote.

comment:2 Changed 9 months ago by car031

  • Milestone set to 8.1
  • Summary changed from Signature fails to record reason for signing to Record reason for signing (compliance with medial standard 21CFR Part 11)
  • Type changed from wish to improvement

comment:3 Changed 9 months ago by car031

  • Summary changed from Record reason for signing (compliance with medial standard 21CFR Part 11) to Record the reason for signing (compliance with medial standard 21CFR Part 11)

comment:4 Changed 9 months ago by car031

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.