Opened 10 years ago

Closed 10 years ago

#209 closed bug (fixed)

Webservices maximum hits limited to 1000

Reported by: ShaneH Owned by:
Priority: minor Milestone: 6.5
Component: Web Services Version: 6.4
Keywords: Cc:

Description

When using the webservices search function, I can only ever receive a maximum of 1000 hits - despite setting maxHits in the search options greater than that.

Change History (6)

comment:1 Changed 10 years ago by ShaneH

Also, the moreHits field is always empty

comment:2 Changed 10 years ago by car031

This is an hard coded limit in the search core module, introduced for performance reasons and no users reached this limit by the way.

If you have 1000 hits your search is quite unusable, in this cse it would be better to navigate the folders tree instead of searching.

This bug will be closed in one day if no reliable motivation will be provided.

comment:3 Changed 10 years ago by ShaneH

1) Because it is not possible to perform a search for different values contained within different template fields, installations with large numbers of documents may run into this issue and need the ability to further filter the results.

For example - I cannot perform a search for "Application Form" in the Document Type field and combine that with a search for "Smith" in the Client Name field. If there are 3000+ application forms, I lose the ability to filter the results for Smith on any hits over the 1000 limit. These documents may well be contained within separate folders within the installation.

2) Statistical analysis of your documents / data is not possible whilst limited to 1000 results.

3) This is an unexpected behaviour as it is not documented.

Whilst I understand that there may be a performance impact if you unlock this limit, would it be possible to allow access to the next set of results, possibly by using a separate webservice?

comment:4 follow-up: Changed 10 years ago by car031

Why don't you do a directory listing and retrieve all the documents?

comment:5 in reply to: ↑ 4 Changed 10 years ago by ShaneH

As noted - the documents may well be contained within separate folders or subfolders meaning that I would have to do many directory listings to retrieve all relevant documents.

comment:6 Changed 10 years ago by car031

  • Milestone set to 6.5
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.